Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Bad audio on some recordings


cosmicjive

Recommended Posts

I've been looking through AVI files that I have downloaded for MAME, SNES, and Sega Genesis, and in every case I have found some videos where the sound is not functioning. You just get static, like wind blowing through a microphone. One example is the file "subroc3d.avi" in the MAME Hi-Quality set, but I've found many files that have this problem. I have verified that the game itself has perfect sound emulation in MAME, so I can't figure out what the story is with the video. I thought maybe I was missing a codec, but I ran the video through VLC (which generally plays virtually anything without needing to mess about with finding the right codec) and it had the same problem.

What's going on here? Can anyone verify that the file I've listed has sound (or verify that they get static as well)? Anyone have a fix?

Link to comment
Share on other sites

Some additional information: I tried re-downloading the file mentioned above, and the new version that I grabbed is exactly the same as before (static). I also downloaded the "normal" quality version of the same game, and I get no sound at all on it -- which I suppose is an improvement over the static, but this game should have sound. I have tried this on multiple systems. I have tried it with the Xvid codec installed, as well as the AC3 codec.

Link to comment
Share on other sites

It's probably when they were originally recorded emulation wasn't as good as it is today. It's not a global issue but if you have more specifics those affected videos can be corrected.

Link to comment
Share on other sites

Yeah this is a problem because there wasn't proper tools in place at the time Circo created the vid's to properly audit the roms...while there have been made some basic tools in this area we still don't have proper tools yet.

For example R. Belmont recently ported pSX's audio code over for Playstation based systems in Mame...which makes a night and day difference in some of the audio channels...the games effected by these changes will likely need to be redone. However once redone...they will likely need to be redone yet again in the future when things change yet again...as may of the Playstation based systems have all kinds of emulation issues...like for one even though there has been this recent upgrade to the audio subsystem it's still not perfect.

More attention needs to be paid to changelog's between Mame revisions...so that video's that need to be redone are and games that are now playable have video's created...however grimly a lot of this is shoved on Circo's shoulders to bear which isn't fair at all to him.

Honestly I need to get my ass in gear and get all the tools in place as I can certainly lower the bar of entry to be able and lend Circo a hand in making high quality vid's.

Anyways if you can create a list of games that have damaged audio streams I can likely automate a check to see if audio is now flagged as working in Mame...which would allow Circo or someone else to redo the proper videos...and I can then create a script that will strip the damaged audio streams out of the others. I actually thought about this stuff a year or two ago but never acted.

If you get the list done I'll have the scripts in place here shortly.

Link to comment
Share on other sites

  • 2 weeks later...

Hi,

I just updated my video set for mame (AVI HQ) and now I have this problem also. My last video set was about 2 years old, it was also from emu movies and all the files had proper sound (if available from mame of course). Now I had the download service utility doing the job for me making a complete update of my videos (more than 2/3 were overwritten with new ones) and many files have only static. Loud white noise.

For example space panic, tecmo world cup, gals panic 3, five a side soccer, great soccer, pro soccer, soccer superstars, n-sub, natsuiro mahjong, Nekketsu grand prix girl, new hidden catch, new lucky 8 line....

All gals panic 2 versions were updated with "not working" videos.

And this was only checking the first 100 or so of the letter N, the soccer games, gals panic and some sudden finds. So to me, this looks like a lot of files are affected.

If the had no sound at all, that wouldn't be such a big problem, but scrolling through a game list and hearing this static is really ugly :-(

Thanks,

Berzerk

Link to comment
Share on other sites

Okay I guess I'll audit the Mame set...probably be a week or two before I'm done with the audit...got more pressing matters right now.

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...
  • 2 months later...

I'm trying to get back to mame I promise. I'm spending all my time on auditing and converting the whole collection and processing submissions from members. If anyone would like to help in submitting captures for mame it would be greatly appreciated.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...