Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Audio but no video


djvj

Recommended Posts

I am making movies in dosbox, using the built-in recorder. It creates an avi that plays fine in vlc, but wmp shows no video. When I convert it in adobe media encoder cs4, no matter where I play it, I get no video but I can hear the audio.

Here is a sample video I made to test. http://www.megaupload.com/?d=BXLR3A3C

I also tried converting the scummvm videos located in "/Work in Progress - These Folders Will Be Cleaned as Sets Are Finalized/Celly/ScummVM InGame Snaps/" and I get the same result. I followed the guide on these forums, granted there isn't much on the conversion step.

What am I missing here?

Link to comment
Share on other sites

DOSBox Info -

If you install CCCP and enable the ffdshow decoder for zmbv you'll be able to view the video in WMP or any player that supports VFW or DirectShow Codec's.

Well actually all you need is ffdshow.

FYI [Linky]

CCCP [Linky]

FFDShow [Linky]

Anyways hope that helps. ;)

I'll look into ScummVM.

Link to comment
Share on other sites

DOSBox Info -

If you install CCCP and enable the ffdshow decoder for zmbv you'll be able to view the video in WMP or any player that supports VFW or DirectShow Codec's.

Well actually all you need is ffdshow.

FYI [Linky]

CCCP [Linky]

FFDShow [Linky]

Anyways hope that helps. ;)

I'll look into ScummVM.

Well vlc doesn't use codecs, it usually plays everything you throw at it. So I did try installing that ffdshow link you gave me and nothing changed. Here is the movie that has no video for me. Can you test it to see if you have no video also? I shouldn't need any codec if all I am doing is converting it in Adobe Media Encoder to flv. Especially when all other flvs for HS work fine. Just trying to figure out if dosbox is making a video that is not an adobe friendly format for it to convert nicely. It was jsut odd to me that I tried the scummVM avis on the ftp and had the same issue...

http://www.megaupload.com/?d=11T85RGS

Link to comment
Share on other sites

Did you enable the decoder as shown in the FYI link? Otherwise it won't work...but once you do you'll be able to watch it in nearly anything. Also VLC uses ffmpeg for the bases of it's decoding...which is also used in ffshow.

Anyways once I enabled zmbv in ffdshow...I was able to view in WMP & convert using Adobe Media Encoder...granted my conversion is only single pass...and well not optimized at all.

[Linky]

Maybe I should give a little more info...okay if you installed CCCP which I recommend for a base codec pack...this allows encoding and decoding using FFDShow.

Anyways go:

Start button\

All Programs\

CCCP\

Settings\

FFDShow VFW Codec Configuration\

Click Decoder Tab

Select Codecs from the left nodless treeview

Under the Format Column locate zmbv

Click the Combobox to the left of it under the Decoder Column

Select libavcodec

Then Click the OK button at the bottom

You should be good to go at this point.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...