Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can't connect to any Video Snap page's.


videogplayer12

Recommended Posts

For some reason and I'm not quite sure why but I can't connect to any of the Video Snap page's whenever I click on any of them to download anything, it just give's me a white blank page and this just started happening about a hour or so ago, I'm also noticing my browser is preforming slightly slower then usual. Is this happening to anyone else? If not, has anyone ever experienced this and know how to fix it? I'm really close to finishing my arcade collection and it would be a shame if I couldn't get all the video files. Thank you for taking the time to read my post.

Link to comment
Share on other sites

I'm not having any issues on my end and haven't heard of anyone else having any problems. What browser are you using?

Link to comment
Share on other sites

Sounds like your browser is bogged down with temp files, run cCleaner to clear out your cookies, browsing history, temp files and do a quick registry scan.

Link to comment
Share on other sites

Today I'm having issues too, I don't know if it's related. I downloaded one file and after that I cannot download other files, I keep receiving the message "You may not download any more files until your other downloads are complete". Obviously I have finished the first download.

Link to comment
Share on other sites

Ok right now it says "Transitioning to a new server. Current Completion ETA: 12:00am PST 05/25/2015" so he's switching on a better server :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...